Glavni Pc In Mac Ali e-poštna sporočila razlikujejo med velikimi in malimi črkami?

Ali e-poštna sporočila razlikujejo med velikimi in malimi črkami?



Obstaja veliko zmede glede tega, ali so e-poštni naslovi občutljivi na velike ali male črke. Nekateri trdijo, da so, drugi pa, da niso. Torej, kdo ima prav? V tem članku bomo preučili, ali e-poštni naslovi razlikujejo med velikimi in malimi črkami.

Ali e-poštna sporočila razlikujejo med velikimi in malimi črkami?

Kaj naredi e-poštni naslov?

E-poštni naslov je sestavljen iz treh delov - lokalnega dela (znanega tudi kot uporabniško ime), znaka @ in domene. Vsak del ima svojo vlogo in zanj veljajo svoja pravila. Tu je hiter pregled.

V skladu s standardom je lahko lokalni del e-poštnega naslova dolg do 64 znakov in je lahko sestavljen iz omejenega nabora znakov. Sem spadajo velike in male črke v latinici, številke od 0 do 9, pika in posebni znaki. Med posebnimi znaki je '[email protected] # $% ^ & * () _- + = [] {} ~. Na domenski del je povezan z znakom @.

Del domene je lahko dolg do 255 znakov. Vsebuje lahko črke latinske abecede (male in velike), številke od 0 do 9 in vezaj. Vezaj domenskega dela ne more začeti ali končati.

Uporabljajo se lahko tudi mednarodni simboli, vendar več o tem kasneje.

Je med velikimi in malimi črkami?

Pravilen odgovor na to vprašanje je tako da kot ne. Po navedbah RFC 5321 , lokalni del e-poštnega naslova razlikuje med velikimi in malimi črkami. To pomeni, da teoretično [e-pošta zaščitena] ni enaka [e-pošta zaščitena]. Vendar imajo ponudniki e-pošte svobodo, da lokalne dele obravnavajo kot velike in male črke.

Na primer, [email protected], [email protected] in [email protected] so teoretično različni e-poštni naslovi. Preprosto je videti, kako bi to lahko povzročilo težave in zmanjšalo uporabniško izkušnjo, če bi se poštni strežnik odločil, da lokalne dele obravnava kot velike in male črke. Številni ponudniki zato lokalni del e-poštnega naslova obravnavajo kot neobčutljiv do velikih in malih črk.

kako izbrisati več sporočil v sel

Kar zadeva domenski del, RFC 1035 določa, da vedno ne razlikuje med velikimi in malimi črkami. To pomeni, da ga lahko napišete z malimi ali malimi črkami ali katero koli kombinacijo obeh, vaš e-poštni naslov pa bo na istem naslovu. V praktični uporabi so [email protected], [email protected] in [email protected] enaki e-poštni naslovi.

V praksi

Čeprav so e-poštni naslovi le delno občutljivi na velike in male črke, je na splošno varno, če zanje štejemo, da ne razlikujejo med velikimi in malimi črkami. Vsi večji ponudniki, kot so Gmail, Yahoo Mail, Hotmail in drugi, lokalne dele e-poštnih naslovov obravnavajo kot neobčutljive. Kot rečeno, preverite pravila ponudnika e-pošte, s katerim želite ustvariti e-pošto.

Glede na prejšnjo točko zgoraj omenjeni RFC 5321 priporoča, da se novi e-poštni naslovi ustvarjajo z malimi črkami, da se prepreči morebitna zmeda in težave z dostavo.

Če pa ima vaš prijatelj ali sodelavec e-poštni naslov s kombinacijo velikih in malih črk, je priporočljivo, da ga napišete tako, kot ko mu pošiljate e-pošto. Če tega ne storite, lahko pride do tega, da e-poštno sporočilo ne bo dostavljeno. Vendar to ni težava z večjimi ponudniki e-pošte, kot so Gmail, Yahoo Mail, Hotmail in drugi.

Poleg tega Gmail ni občutljiv na pike, ki jih najdemo v lokalnem delu e-pošte, ko gre za identifikacijo uporabniškega računa. To pomeni, da če račun [email protected] obstaja, ne boste mogli registrirati [email protected] ali [email protected]

Internacionalizacija

Prvotno je bilo mogoče e-poštne naslove registrirati samo z uporabo črk latinske abecede, številk in omejenega nabora posebnih znakov ASCII. Vendar IETF (Internet Engineering Task Force) je nato razvil pravila in standarde za vključitev mednarodnih znakov.

RFC6530 je bil prvi, ki je vključeval in urejal uporabo mednarodnih znakov. RFC6531 razširil na pravila in standarde. Nato so bila pravila in standardi posodobljeni z RFC6532 in RFC6533 .

Zdaj lahko registrirate e-poštni naslov z uporabo številnih abeced, znakov in skriptov. Nekateri najpogosteje uporabljeni znaki vključujejo latinico z diakritiko, grško abecedo, tradicionalne kitajske znake, japonske znake (hiragana, katakana in kanji), cirilico, več indijskih pisav in vrsto drugih.

Vključitev in združljivost z mednarodnimi e-poštnimi naslovi se razlikuje od ponudnika do ponudnika. Tudi nekateri največji ponudniki niso popolnoma združljivi z mednarodnimi naslovi. Google vam na primer dovoli, da pošljete e-poštno sporočilo na mednarodni naslov, vendar vam ne dovoli, da ga ustvarite. Outlook 2016 ima podobno funkcionalnost.

Zaključek

V nasprotju z delom imena domene je lokalni del e-poštnega naslova občutljiv na velike in male črke. Kot rečeno, se mnogi ponudniki e-pošte iz praktičnih razlogov odločijo za prezrtje občutljivosti malih in velikih črk in spodbujajo ljudi k ustvarjanju e-poštnih sporočil samo z malimi črkami.

Zanimivi Članki

Izbira Urednika

Kako nastaviti tipkovnico z osvetlitvijo na vedno vklopljeno
Kako nastaviti tipkovnico z osvetlitvijo na vedno vklopljeno
Varno je reči, da je računalniška doba postala polnoletna. Minili so dnevi, ko v temi niste mogli tipkati brez namizne svetilke ali kakšnega drugega vira svetlobe. Danes ima večina računalnikov a
Spremenite število dni, da se vrnete na prejšnjo različico sistema Windows
Spremenite število dni, da se vrnete na prejšnjo različico sistema Windows
V operacijskem sistemu Windows 10 ima uporabnik le 10 dni časa, da opazi in preuči morebitne težave z novo zgradbo in jo odstrani. Število dni za vrnitev na prejšnjo različico sistema Windows 10 je mogoče spremeniti.
Kako pošiljati in prejemati besedilna sporočila v računalniku brez telefona
Kako pošiljati in prejemati besedilna sporočila v računalniku brez telefona
Pošiljanje kratkih sporočil je zelo priročno komunikacijsko sredstvo - zlasti za kratka sporočila ali pogovore, ki si ne zaslužijo telefonskega klica. Kaj pa, če morate nekomu sporočiti in telefona nimate pri sebi? Ali morda ti
Kako izbrisati vse opombe v programu Microsoft Word
Kako izbrisati vse opombe v programu Microsoft Word
Opombe in opombe so lahko zelo koristne, če želite dokumentu dodati komentarje, pojasnila in sklice. Omogočajo enostavno ločevanje dodatnih opomb od besedila. Vendar jih boste včasih dobili
PUBG: Kako igrati z boti
PUBG: Kako igrati z boti
Leta 2020 se je PUBG Corp, razvijalec znane streljačine battle royale, PUBG, odločil uvesti bote v javno srečanje. To je bilo implementirano v posodobitvi 7.2, razlog za to odločitev pa je bil povečati vrzel v spretnostih. Novejši igralci
Prenesite Deskthemepack Installer za Windows 7
Prenesite Deskthemepack Installer za Windows 7
Deskthemepack Installer za Windows 7. Deskthemepack Installer je edinstvena rešitev za uporabnike sistema Windows 7, ki omogoča namestitev tem Windows 8 z enim klikom. Pustite komentar ali si oglejte celoten opis Avtor: Sergey Tkachenko, https://winaero.com. https://winaero.com Prenesite »Deskthemepack Installer for Windows 7« Velikost: 58,26 Kb AdvertismentPCRepair: Odpravite težave s sistemom Windows. Vse. Povezava za prenos: kliknite
11 načinov, kako to popraviti, ko Waze ne deluje
11 načinov, kako to popraviti, ko Waze ne deluje
Kaj storiti, ko Waze ne naloži zemljevida, GPS ne deluje ali je kakšna druga težava z Waze. Običajno samo znova zaženite aplikacijo, če pa Waze ne deluje, morate samo počakati. Preizkusiti je še več, zato bomo obravnavali tudi to.